 |
» |
|
|
|
NAMEsd — Create, distribute, install, monitor, and manage software SYNOPSISsw<task>
[XToolkit Options]
[-r|-d]
[-i]
[-l]
[-p]
[-R]
[-u]
[-v]
[-V]
[-a
attribute]
[-c
catalog]
[-C
session_file]
[-D
acl_entry]
[-f
software_file]
[-F
acl_file]
[-J
jobid]
[-l
level]
[-M
acl_entry]
[-Q
date]
[-s
source]
[-S
session_file]
[-t
target_file]
[-x
option=value]
[-X
option_file]
[software_selections]
[@
target_selections] RemarksHP-UX's software distributor, SD-UX, is included with the HP-UX
Operating System and manages software on the
local
host only. To install and manage software simultaneously on multiple
remote
hosts (including HP-UX, other UNIX® platforms, Windows NT®, and PCs)
from a central controller, you must purchase the
HP OpenView Software Distributor
which provides extended software management capabilities. Information specific
only
to the OpenView product is marked with a heading similar to the following:
The following information applies to HP OpenView Software Distributor only.
DESCRIPTIONThe SD commands are:
sd
- create and monitor software jobs
(HP OpenView Software Distributor only). swacl
- modify the Access Control Lists (ACLs) which protect software products. swagentd
- serve local or remote SD software management tasks. swask
- ask for a user response. swcluster
- configure diskless clients (HP-UX 10.* only). swconfig
- configure, unconfigure, or reconfigure installed software. swcopy
- copy software products for subsequent installation or distribution. swgettools
- retrieve the SD product from new media. swinstall
- install and configure software products. swjob
- monitor job progress and log files.
(HP OpenView Software Distributor only). swlist
- display information about software products. swmodify
- modify software product information in a target root or depot. swpackage
- package software products into a distribution directory or tape. swreg
- register or unregister depots or roots. swremove
- unconfigure and remove software products. swverify
- verify software products.
Related commands include:
mk_kernel
- build a bootable HP-UX kernel (HP-UX only). pushAgent
- install the HP OpenView Software Distributor agent on remote systems.
The following sections highlight the features that these commands
support. Interactive OperationBy default, all SD commands except
swask
operate in a non-interactive mode. However,
swcopy,
swinstall,
swlist,
and
swremove
commands also support a graphical user interface (GUI).
To invoke the GUIs, enter the command without any command-line options
or use the
-i
option. The command-line versions of
swinstall
and
swconfig
can be interactive if the
ask
option is set to
true. The following information applies to HP OpenView Software Distributor only.
To invoke the HP OpenView Software Distributor GUI, use
sd
command. This provides the central interactive interface for creating
and monitoring software jobs. Distributed OperationAll of the commands except
swask,
swpackage,
and
swmodify
use a distributed model of operation. The commands act as the
controller for distributed operations, managing the specific software
management tasks. For each
target_selection,
an SD agent process performs the task:
swagent
- perform software management tasks as the agent of an SD command.
Communication between the command and each agent, plus other target
host activities are facilitated by an SD daemon process:
swagentd
- serve local or remote software management tasks.
The following PC information applies only to HP OpenView Software Distributor.
For each PC controller
target_selection,
a single Windows application combines the
swagent
and
swagentd
functionality:
SWAGENTD.EXE
- perform software management tasks, serve local PC software for distribution.
Each PC running the
SWAGENTD.EXE
is a PC controller. When distributing PC software, it acts as a fanout server
to PC targets. These targets run SD PC agent programs to perform the actual
software installation tasks. Software Job ManagementThe following paragraph applies only to HP OpenView Software Distributor.
Most SD commands create job information that records the job definition (in a session file),
status and log
information for the job.
Jobs can be executed immediately, or scheduled for later execution.
The user can browse the scheduled, active, and completed jobs
using either the command line or interactive interfaces. Secure OperationSD uses Access Control Lists (ACLs) to authorize a user attempting to
create, modify, or read software products in a depot or installed to
a root file system. The superuser can grant specific local and remote
users specific access permissions to a target host, a target depot, and/or
a target root file system. Because files are loaded and scripts are run as superuser, granting
write permission (to install software) on a root file system or insert
permission (to create a new root) on a host, effectively gives the
user superuser privileges. SD uses a method based on credentials and passwords to authenticate
the user and the SD command performing a given operation. Flexible Policy ControlMany policies and behaviors for the SD commands
can be controlled via the appropriate command options. Options can be defined
in an SD
defaults
file, specified on the command-line invocation of a command, or specified
in the GUI. Preview, Diagnostics and LoggingAll commands except
swlist
and
swjob
log major events on the controller host and detailed events on the
target hosts. If both source and target machine are updated to HP-UX version 10.30
or later, the system administrator at the source depot machine
can track
which
user pulls
which
software from a depot on the source machine and
when
the software is pulled. Refer to the
swagent(1M)
source_depot_audit
option for more information. The following paragraph applies only to HP OpenView Software Distributor.
You can use the SD interactive interface (invoked using the
sd
command) and the
swjob
command line interface to monitor job progress and to view
controller and target log files. The
swconfig,
swcopy,
swinstall,
swmodify,
swpackage,
and
swremove
commands support a preview mode, where the commands will proceed through
the analysis phase, then exit. The preview mode only applies to non-interactive operations, since the
GUIs wait for confirmation after analysis. In the interactive mode, you
can resolve invalid conditions that the commands discover before they
actually begin loading or removing files. Software ProductsSoftware products are organized in a multi-level hierarchy:
bundles,
products,
subproducts,
and
filesets.
The actual files that make up a product are packaged into filesets.
The
software_selections
for an SD command can specify bundles, products,
individual subproducts, and/or individual filesets. Compatible SoftwareSoftware products specify what machine types and operating systems they support (i.e. are
compatible with). The
swconfig,
swinstall,
and
swverify
commands can detect and/or enforce the use of compatible software. Dependencies Between SoftwareThe
swask,
swconfig,
swcopy,
swinstall,
swremove,
and
swverify
commands support dependencies between filesets and other
filesets and products. If a
software_selection
specifies a dependency on
other filesets and/or products,
the commands will automatically select that software.
An exception is
swremove,
which can automatically select dependent software (filesets and/or products
that depend on the
software_selections). By default, all dependencies must be resolved before a command will
proceed. The user can override this policy using the
enforce_dependencies
option. SD supports two types of dependencies:
prerequisites
that must be installed and configured before the dependent fileset is installed
and configured (respectively);
and
corequisites
that must be installed and configured before the dependent is usable.. Product Location and Multiple VersionsThe
swinstall
command can install a software product to an
alternate product location
instead of the default product directory specified by the
vendor. (This directory location is the root directory of
all the product's files.) The
swinstall
command can also install multiple versions of
a software product to a single target system, each in a unique
product location. The software management commands,
swconfig,
swlist,
swremove,
and
swverify
allow a user to select a specific product from the multiple installed
versions by specifying the product location as part of
the
software_selection. Alternate Root Directory and Depot DirectoryBy default, the
swinstall,
swlist,
swverify,
and
swremove
commands operate on the primary root file system of a target host,
namely "/".
The user can specify an alternate root directory to these commands,
meaning a directory other than "/" that will
eventually be the root of some target host (e.g. building a test system by
mounting its root file system). The
swconfig
command only operates on software installed to
the primary root file system, "/". When operating on a depot, the
swpackage,
swcopy,
swlist,
swverify,
and
swremove
commands by default use the depot located at
/var/spool/sw.
The user can also specify an alternate depot directory to these commands. Disk Space AnalysisThe
swcopy,
swinstall,
and
swpackage
commands perform a disk space analysis on the
target_selections
to ensure that enough free disk space is available to perform the
task. Before performing any disk space analysis, these commands (and also
swverify
and
swremove)
execute the
mount(1M)
command to mount all file systems listed in each target's file system table
(/etc/fstab
or equivalent). This ensures that files are not loaded into a directory
below a future mount point. The user can override this mounting policy
using the
mount_all_filesystems
option. Control ScriptsThe
swask,
swconfig,
swinstall,
swremove,
and
swverify
commands execute vendor-defined control scripts
to perform checks and/or other tasks beyond those explicitly performed
by the commands. The
swask
command can run request scripts to request user responses. The
swinstall
and
swconfig
commands can also run request scripts. For
swinstall
and
swremove,
a fileset and/or product can include a
check script to perform an analysis of each
target_selection
(target host).
If this analysis fails, the script can: prevent the
fileset/product from being installed/removed or abort the entire session. In addition,
swinstall
and
swremove
can execute scripts
immediately before and immediately after the fileset/product
has been installed or removed.
These scripts usually perform additional file install or remove
operations. The
swconfig,
swinstall,
and
swremove
commands will also execute
configuration and unconfiguration scripts on an installed fileset/product
to configure or unconfigure the system for the software. The
swverify
command will execute a
verification script which can analyze the configured fileset/product
to verify that it is configured properly. Software StatesThe SD commands transition products and filesets through a number of
states. During installation, software is transitioned through the following
states: non-existent, TRANSIENT, INSTALLED, and CONFIGURED. During
removal, software is transitioned through these states: CONFIGURED,
INSTALLED, TRANSIENT, and non-existent. When packaging or copying software into a depot, the
software is transitioned through the following states: non-existent, TRANSIENT, and
AVAILABLE. When removing software from a depot, the software is transitioned
through these states: AVAILABLE, TRANSIENT, and non-existent. If a task fails during any TRANSIENT state, the state is set to
CORRUPT. Session FilesEach invocation of an SD command defines a task session. Most SD
commands automatically save options, source information, software
selections, and target selections before the task actually commences.
You can build, save, and reuse additional sessions with most commands. Software and Target ListsMost SD commands support software and target selections from separate
input files. You can reuse files containing sets of software or target
configurations as input to the commands. OptionsThe following options are supported by one or more of the SD
commands. Refer to the manual pages for each command for the options
specific to that command. - XToolKit Options
The interactive commands support a subset of the standard X Toolkit
options to control the appearance of the GUI. The supported options
are:
-bg,
-background,
-fg,
-foreground,
-display,
-name,
-xrm.
and
-synchronous.
See the
X(1)
manual page for a definition of these options. - -d
Causes the command to operate on
target_selections
which are software depots rather than root directories. - -r
(Optional) Causes the command to operate on
target_selections
that are alternate root directories (root file systems other than
/). Note that you cannot use this option to relocate software during
installation. You must use the
l=location
syntax in the software selection component. - -i
Runs the command in interactive mode (Graphical User Interface). - -l
(HP-UX 10.* only)
Runs the command in
linkinstall
mode, which makes software installed under a server's
shared root
available to a diskless client's
private root. When run in
linkinstall
mode,
swinstall:
Creates NFS mounts to the software to make it accessible from the target.
This may involve delayed mounting for alternate roots. Modifies the target's
fstab
file. Modifies the source's
exports
file to add mount permission for the target.
Mounts are created by examining the
share_link
product attribute.
Not all products support
linkinstall.
Some products may be visible without creating a new mount if they
reside under an existing one. - -p
Previews the task by executing the session through
the analysis phase and exiting before the command begins to perform the actual task.
This option only applies to non-interactive sessions. - -R
Recursively include all objects to the fileset level using
swlist,
(and to the end_target level using the HP OpenView Software Distributor
swjob
command). - -u
Undo variation of the operation, unconfiguring software using
swconfig,
unregistering the specified objects using
swreg,
(or removing the specified jobs using the HP OpenView Software Distributor
swjob
command). - -v
Turns on verbose output to stdout. (The command log file is not affected
by this option.) By default, verbose output is enabled for all the SD
commands. - -V
List the SDU data model revisions that
swpackage
supports. - -a attribute
Specifies particular attributes to display or modify using
swlist,
swmodify,
(or the HP OpenView Software Distributor
swjob
command). - -c catalog
Specifies the pathname of an exported catalog which
stores copies of the response files created by request scripts. - -C session_file
Save the current options and operands to
session_file.
You can enter a relative or absolute path with the file name.
The default directory for session files is
$HOME/.sw/sessions/.
You can recall a session file with the
-S
session_file
option. From an interactive session, you can save session information into a
file at any time with the
File/Save Session
or
File/Save Session As
option. You can save session information from a command-line session
with the
-C
session_file
option.
In addition, each command automatically creates a session
file of the most recent session information and names the file
$HOME/.sw/sessions/sw<task>.last. - -D acl_entry
Deletes an existing entry from the ACL associated with the
specified objects using
swacl. - -f software_file
Read the list of
selections
from
software_file
instead of (or in addition to) the command line operands. - -F acl_file
Assigns the ACL contained in
acl_file
to the specified object
using
swacl. - -J job_id
(HP OpenView Software Distributor only)
Executes the previously scheduled job. This option is used by the
swagentd
to initiate scheduled jobs. - -l level
List all objects at the specified
level
when using
swlist,
or define the level of the objects when using
swacl,
or
swreg. - -M acl_entry
Adds a new ACL entry or changes the permissions of an existing entry
using
swacl. - -Q date
(HP OpenView Software Distributor only)
Schedules the command for the specified date and time. - -s source
Specifies source depot, PSF file, or tape from which
software will be installed,
copied, listed, or packaged. - -S session_file
Execute
swinstall
or
swcopy
based on the options and operands saved from a previous session,
as defined in
session_file.
You can save session information to a file with the
-C
session_file
option. - -t target_file
Read the list of
target_selections
from
target_file
instead of (or in addition to) the command line operands. - -x option=value
Set the session
option
to
value
and override the default value (or a value in an alternate
option_file
specified with
the
-X
option).
Multiple
-x
options can be specified. - -X option_file
Read the session options and behaviors from
option_file.
These values defined in this file override the default values.
OperandsMost SD commands support two types of operands:
software selections
followed by
target selections.
These operands are separated by the "@" (at) character. This syntax
implies that the command operates on "selections at targets". Software SelectionsThe
selections
operands consist of
software_selections
for most SD commands.
For the
swjob
(HP OpenView Software Distributor)
and
swreg
commands, the selections can be
job_ids
and
roots_or_depots
respectively. The SD
commands support the following syntax for each
software_selection:
bundle[.product[.subproduct][.fileset]][,version]
product[.subproduct][.fileset][,version] The
version
component has the form:
[,r <op> revision][,a <op> arch][,v <op> vendor]
[,c <op> category][,l=location][,fr <op> revision]
[,fa <op> arch]
location
applies only to installed software and refers to software installed to
a location other than the default product directory. fr
and
fa
apply only to filesets. The
<op>
(relational operator) component can be of the form:
which performs individual comparisons on dot-separated fields. For example,
r>=B.10.00
chooses all revisions greater than or equal to
B.10.00.
The system compares each dot-separated field to find
matches. Shell patterns are not allowed with these operators. The
=
(equals) relational operator lets you specify selections for
swlist,
swpackage,
and
swmodify
with the following
shell wildcard and pattern-matching notations:
For example, the expression
r=1[01].*
returns any revision in version 10 or version 11. All version components are repeatable within a single specification (e.g.
r>=A.12,
r<A.20).
If multiple components are used, the selection must match all
components. Fully qualified software specs include the
r=,
a=,
and
v=
version components even if they contain empty strings. No space or tab characters are allowed in a software selection. The software
instance_id
can take the place of the version component. It has the form:
within the context of an exported catalog, where
instance_id
is an integer that distinguishes versions of products and bundles with
the same tag.
The
*
software specification selects all products. It is not allowed when
removing software from the root directory
(/). Target SelectionsThe SD commands support this syntax for each
target_selection.
The
:
(colon) is required if both a host and directory are specified. The following PC information applies only to HP OpenView Software Distributor.
The
swinstall
and
swjob
commands support the following syntax for specifying PCs:
[pc_controller][::][pc_target]
The PC controller is a fanout server. The PC target may be a PC machine, user, or group
name. Valid targets for a PC controller can be listed using: swlist -l machine|user|group
PC targets can be further qualified for whether they refer to a
PC machine, user, or group type with the following syntax:
name[,t=type][,k=address] The
type
must be specified when a name applies to more than one of a
machine,
user,
or
group.
(The
address
is used internally for machines and is generally not needed on the command line.) The keyword
*
can be substituted for
pc_target,
specifying an installation to all target machines: @ pc_controller::*
EXTERNAL INPUTS AND INFLUENCESDefault OptionsIn addition to the standard options, several SD behaviors and policy options
can be changed by editing the default values found in:
- /var/adm/sw/defaults
the system-wide default values. - $HOME/.swdefaults
the user-specific default values.
Values must be specified in the defaults file using this syntax: [command_name.]option=value The optional
command_name
prefix denotes one of the SD commands. Using the prefix limits the
change in the default value to that command. If you leave the prefix
off, the change applies to all commands. You can also override default values from the command line with the
-x
or
-X
options: command -x option=value
command -X option_file The following section lists all of the keywords supported by the SD commands.
The keywords that are supported for individual commands are also listed
in each command's manual page.
If a default value exists, it is listed after the "=". The commands
that this option applies to are also specified. - agent=/usr/lbin/swagent
The location of the agent program invoked by the daemon. Applies to
swagentd. - agent_auto_exit=true
Causes the target agent to automatically exit after Execute phase, or after
a failed Analysis phase. This is forced to
false
when the controller is using an interactive UI, or when
-p
(preview) is used. This enhances network reliability and performance.
The default is
true
means the target agent automatically exits when appropriate.
If set to
false,
the target agent will not exit until the controller ends the session. Applies to
swconfig,
swcopy,
swinstall,
swremove,
swverify. - agent_timeout_minutes=10000
Causes a target agent to exit if it has been inactive for the
specified time. This can be used to make target agents more quickly
detect lost network connections since RPC can take as long as 130
minutes to detect a lost connection. The recommended value is the
longest period of inactivity expected in your environment. For command
line invocation, a value between 10 minutes and 60 minutes is
suitable. A value of 60 minutes or more is recommended when the GUI
will be used. The default of 10000 is slightly less than 7 days. Applies to
swcopy,
swinstall,
swjob,
swlist,
swremove,
swverify. - allow_downdate=false
Prevents the installation of an older revision of fileset that already
exists at the targets. (Many software products do not support
"downdating".) If set to
true,
the older revision can be installed. Applies to
swinstall. - allow_incompatible=false
Requires that the software products which are being installed be
"compatible" with the target selections. (All of the target selections
must match the list of supported systems defined for each selected
product.) If set to
true,
target compatibility is not enforced. Applies to
swconfig,
swinstall,
and
swverify. - allow_multiple_versions=false
Prevents the installation or configuration of another, independent
version of a product when a version already is already installed or configured
at the target. If set to
true,
another version of an existing product can be installed into a new
location, or can be configured in its new location. Multiple versions
can only be installed if a product is locatable. Multiple configured
versions will not work unless the product supports it. Applies to
swconfig,
swinstall,
and
swverify. - alternate_source=
Defines the alternate source which the agent will use
when the
use_alternate_source
option is set to
true.
The alternate source is specified using the syntax:
If the host portion is not specified, then the local
host is used. If the path portion is not specified, then the path
sent by the command is used.
The protocol sequence and endpoint given by the option
swagent.rpc_binding_info
are used when the agent attempts to contact an alternate source depot. Applies to
swagent. - ask=true (swask only)
- ask=false (swconfig and swinstall)
Executes a
request script,
which asks for a user response. If
ask=as_needed,
swinstall
executes the request script only if a response file does not already
exist in the control directory. See
swask(1M)
for more information on request scripts. Applies to
swask,
swconfig,
and
swinstall. - auto_kernel_build=true
Normally set to true. Specifies whether the removal of a kernel
fileset should rebuild the kernel or not. If the kernel rebuild succeeds,
the system automatically reboots. If set to false, the system
continues to run the current kernel. If the
auto_kernel_build
option is set to
true,
the
autoreboot
option must also be set to
true.
If the
auto_kernel_build
option is set to
false,
the value of the
autoreboot
option does not matter. Applies to
swremove
only. - autoreboot=false
Prevents the installation or removal of software requiring a reboot
from the non-interactive interface. If set to
true,
then software can be installed or removed, after which the target
system(s) will automatically reboot. An interactive session always asks for confirmation before software requiring
a reboot is installed or removed. If the
auto_kernel_build
option is set to
true,
the
autoreboot
option must also be set to
true.
If the
auto_kernel_build
option is set to
false,
the value of the
autoreboot
option does not matter. Applies to
swinstall
and
swremove. - autorecover_product=false
Causes
swinstall
to remove the original files as they are updated.
If an error occurs during the installation (e.g. network failure),
then the original files are lost, and the installation must
be re-tried. If set to
true,
all files are saved as backup copies until all filesets in the current
product loading are complete; then they are removed. At the cost of a
temporary increase in disk space and slower performance, this allows for
automatic recovery of the original filesets in that product if the
load fails. Applies only to
swinstall. - autoremove_job=false
This option applies only to HP OpenView Software Distributor.
Controls automatic job removal of completed jobs. If the job is
automatically removed, job information (job status or target log files)
cannot be queried with
swjob. Install jobs to PCs can not be automatically removed. They should not
be removed until the job completes on all PC targets. - autoselect_dependencies=true
Controls the automatic selection of prerequisite and corequisite
software that is not explicitly selected by the user. When set to
true,
the requisite software is automatically selected for configuration.
When set to
false,
requisite software which is not explicitly selected is not
automatically selected for configuration. Applies to
swconfig,
swcopy,
swinstall,
and
swverify. - autoselect_dependents=false
Controls the automatic selection of dependent
software that is not explicitly selected by the user. A dependent is the
opposite of a requisite. A dependent fileset has established either a
prerequisite or a corequisite on the fileset under discussion.
Specifying
true
causes dependent software to be automatically selected for the operation.
The default,
false
causes dependent software, which is not explicitly selected, to not be
automatically selected for the operation. Applies to
swconfig
and
swremove. - autoselect_patches=true
Automatically selects the latest patches (based on superseding
and ancestor attributes) for a software object that a user selects for a
swinstall
or
swcopy
operation. When set to
false,
the patches corresponding to the selected object will not be
automatically selected. The
patch_filter
option can be used in conjunction with
autoselect_patches. Applies to
swask,
swinstall,
and
swcopy. - autoselect_reference_bundles=true
If
true,
bundles that are
sticky
will be automatically installed, or copied, along with the software it is
made up of.
If
false,
the software can be installed, or copied, without automatically including
sticky
bundles that contain it. For
swremove,
if set to
true,
any bundle with the is_sticky attribute
set to true is removed automatically
when the last of its contents is removed.
If set to
false,
the sticky bundles will not be automatically removed. Applies to
swcopy,
swinstall,
and
swremove. - check_contents=true
Causes
swverify
to verify the time stamp, size, and checksum attributes of files.
If set to
false,
these attributes are not verified. Applies to
swverify. - check_permissions=true
Causes
swverify
to verify the mode, owner, UID, group, and GID attributes of
installed files.
If set to
false,
these attributes are not verified. Applies to
swverify. - check_requisites=true
Causes
swverify
to verify that the prerequisite and corequisite dependencies of the software
selections are being met.
If set to
false,
these checks are not performed. Applies to
swverify. - check_scripts=true
Causes
swverify
to run the fileset/product verify scripts for installed software.
If set to
false,
these scripts are not executed. Applies to
swverify. - check_volatile=false
Causes
swverify
to not verify those files marked as volatile (i.e. can be changed).
If set to
true,
volatile files are also checked (for installed software). Applies to
swverify. - codeword=
Provides the "codeword" needed to unlock protected HP CD-ROM software. Some HP software products are shipped on CD-ROM as "protected"
products. That is, they cannot be installed or copied unless a
"codeword" and "customer ID" are provided. The codeword is found on
the CD-ROM certificate which you received from HP. You may use this
default specification on the command line or the SD-UX Interactive
User Interface to enter the codeword. This default stores the codeword for future reference; it needs to be
entered only once. If a new HP product is purchased and a previous
codeword has already been entered for that CD-ROM, just enter the new
codeword as usual and the codewords will be merged internally. - compress_cmd=/usr/contrib/bin/gzip
Defines the command called to compress files
before installing, copying or packaging.
If the
compression_type
option is set to other than
gzip
or
compress,
this path must be changed. Applies to
swpackage
and
swagent. - compress_files=false
If set to
true,
files are compressed, if not already compressed, before transfer from
a source.
This will enhance
performance on slower networks for
swcopy
and
swinstall.
and will result in smaller depots
for
swcopy
and
swpackage,
unless the
uncompress_files
is also set to
true. Applies to
swcopy,
swinstall,
and
swpackage. - compression_type=gzip
Defines the default compression type used by the agent when it compresses
files during or after transmission. If
uncompress_files
is set to false, the
compression_type
is recorded for each file compressed so that the
correct uncompression can later be applied during a
swinstall,
or a
swcopy
with
uncompress_files
set to true. The
compress_cmd
specified must produce
files with the
compression_type
specified. The
uncompress_cmd
must be able to process files of the
compression_type
specified unless the format is
gzip,
which is uncompressed by the internal uncompressor
(funzip). Applies to
swagent. - config_cleanup_cmd=/usr/lbin/sw/config_clean
Defines the script called by the agent to perform release-specific
configure cleanup steps. Applies to
swagent. - control_files=
When adding or deleting control file objects, this option lists the tags
of those control files. There is no supplied default.
If there is more than one tag, they must be separated by whitespace
and surrounded by quotes. Applies to
swmodify. - controller_source=
Specifies the location of a depot for the controller to access to
resolve selections. Setting this option can reduce network traffic
between the controller and the target. Use the target selection syntax
to specify the location:
This option has no effect on which sources the target uses and is
ignored when used with an Interactive User Interface. Applies to
swcopy,
swconfig,
swinstall,
swremove, and
swverify. - create_target_acls=true
If creating a target depot,
swpackage
will create Access Control Lists (ACLs) for the depot (if it is new)
and all products being packaged into it. If set to
false,
and if the user is the superuser,
swpackage
will not create ACLs. (The
swpackage
command never creates ACLs when software is packaged on to a
distribution tape.) Applies to
swpackage. - create_target_path=true
Causes the agent to create the target directory if it does not already
exist. If set to
false,
a new target directory will not be created. This option can prevent
the erroneous creation of new target depots. Applies to
swcopy
and
swinstall. - customer_id=
This number, also printed on the Software Certificate, is used to
"unlock" protected software and restrict its installation to a
specific site or owner. It is entered using the
-x
customer_id=
option or by using the Interactive User Interface. The
customer_id
can be used on any HP-UX 10.0X compatible
HP9000 system. - defer_configure=false
Causes
swinstall
to automatically configure the
software_selections
after they are installed.
When an
alternate root directory is specified,
swinstall
never performs the configuration task, since only
hosts using the software should be configured.
If set to
true,
this option allows
configuration to be deferred even when the root directory is
/. When installing a successive version of a product, it will not
be configured if another version is already configured. The
swconfig
command must be run separately. Applies to
swinstall. - distribution_source_directory=/var/spool/sw
Defines the default distribution directory to read as the source (when
the
source_type
is
directory).
The
-s
option overrides this default. Applies to
swcopy,
swinstall,
and
swpackage. - distribution_target_directory=/var/spool/sw
Defines the default distribution directory of the target depot.
The
target_selection
operand overrides this default. Applies to
swacl,
swcopy,
swlist,
swmodify,
swpackage,
swreg,
swremove,
and
swverify. - distribution_target_serial=/dev/rmt/0m
Defines the default location of the target tape device file.
The
target_selection
operand overrides this default. Applies to
swpackage. - enforce_dependencies=true
Requires that all dependencies specified by the
software_selections
be resolved either in the specified source, or at the
target_selections
themselves. The
swconfig,
swcopy,
and
swinstall
commands will not proceed unless the
dependencies have also been selected or already exist at the target in
the correct state (INSTALLED, CONFIGURED, or AVAILABLE). This prevents
unusable software from being installed on the system. It also ensures
that depots contain usable sets of software. For
swremove,
if a selected fileset has dependents (i.e. other software depends on the
fileset) and they are not selected, do not remove the selected filesets. If set to
false,
dependencies will still be checked, but not enforced. Corequisite
dependencies, if not enforced, may keep the selected software from
working properly. Prerequisite dependencies, if not enforced, may cause
the installation or configuration to fail. Applies to
swconfig,
swcopy,
swinstall,
swremove,
and
swverify. - enforce_dsa=true
Prevents a command from proceeding past the analysis phase if the disk
space required is beyond the available free space of the impacted
file systems. If set to
false,
then the install, copy, or package operation will use the file systems'
minfree space and may fail
because it reaches the file system's absolute limit. Applies to
swcopy,
swinstall,
and
swpackage. - enforce_kernbld_failure=true
Prevents
swinstall
from proceeding past the kernel build phase if the kernel build processes fail.
If set to
false,
then the install operation will continue
(without suspension if in the interactive mode)
despite failure or warnings from either the system
preparation process or the kernel build process. Applies to
swinstall. - enforce_scripts=true
If a fileset/product
checkinstall
or
checkremove
script fails (i.e. returns with exit code 1), none of the filesets in that
product will be installed or removed.
If set to
false,
the install or remove operation will proceed even when a check script fails. Applies to
swinstall
and
swremove. - files=
When adding or deleting file objects, this option lists the pathnames
of those file objects. There is no supplied default.
If there is more than one pathname, they must be separated by whitespace. Applies to
swmodify. - follow_symlinks=false
Do not follow symbolic links in the package source files, but include
the symbolic links in the packaged products. A value of
true
for this keyword causes
swpackage
to follow symbolic links in the package source files and include the
files they reference in the packaged products. Applies to
swpackage. - force_job_removal=false
This option applies only to HP OpenView Software Distributor.
By default, the job information is removed from the central controller
only after removing the job information stored on each of the targets
succeeds. If the job should be removed regardless of the success of
the removal of job information from targets, set this option to
true. Applies to
swjob. - force_single_target=false
This option applies to HP-UX 10.* only.
This option applies only to the Interactive User Interface when no
SD-OV license is in effect on a system that is a diskless server. It
causes
swremove
to run in a single target mode, even though a diskless server normally causes
swremove
to run in multi-target mode. - include_file_revisions=false
Do not include each source file's revision attribute in the products being packaged.
Because this operation is time consuming,
by default the revision attributes are not included.
If set to
true,
swpackage
will execute
what(1)
and possibly
ident(1)
(in that order) to try to determine a file's revision attribute. Applies to
swpackage. - install_cleanup_cmd=/usr/lbin/sw/install_clean
Defines the script called by the agent to perform release-specific install
cleanup steps immediately after the last postinstall script has been run.
For an OS update, this script should at least remove commands that were
saved by the
install_setup
script. This script is executed after all filesets have been
installed, just before the reboot to the new operating system. Applies to
swagent. - install_setup_cmd=/usr/lbin/sw/install_setup
Defines the script called by the agent to perform release-specific install
preparation. For an OS update, this script should at least copy commands
needed for the checkinstall, preinstall, and postinstall scripts to a path
where they can be accessed while the real commands are being updated.
This script is executed before any kernel filesets are loaded. Applies to
swagent. - job_polling_interval=30
This option applies only to HP OpenView Software Distributor.
Defines the polling interval, in minutes, used by the daemon.
It specifies how often a PC install job will be polled in order
to cache the progress of remote targets on the controller. Applies to
swinstall. - job_title=
This option applies only to HP OpenView Software Distributor.
This is an ASCII string giving a title to a job. It is displayed
along with the job ID to provide additional identifying information
about a job when
swjob
is invoked. Applies to
swconfig,
swcopy,
swinstall,
swremove,
and
swverify. - kernel_build_cmd=/usr/sbin/mk_kernel
Defines the script called by the agent for kernel building. Applies to
swagent. - kernel_path=/stand/vmunix
Defines the path to the system's bootable kernel. This path is passed
to the
kernel_build_cmd
via the
SW_KERNEL_PATH
environment variable. Applies to
swagent. - layout_version=1.0
Specifies the POSIX
layout_version
to which the SD commands conform when writing distributions and
swlist
output. Supported values are "1.0" (default) and "0.8". SD for HP-UX
version 10.10 and later can read or write either layout version. SD object and attribute syntax conforms to the
layout_version 1.0
specification of the
IEEE POSIX 1387.2 Software Administration
standard. SD commands still accept the keyword names associated
with the older layout version, but you should use
layout_version=0.8
only to create distributions readable by older versions of SD. The version used by
swpackage
can be controlled by specifying the
layout_version
attribute in the product specification file (PSF). However, if the
layout_version
attribute in the PSF is 1.0, the
is_locatable
attribute defaults to true in all cases, and must be explicitly set to
false. (See
swpackage(4)
for more information on PSFs.) Layout version 1.0 adds significant functionality not recognized by
systems supporting only 0.8, including:
Category class objects (formerly the
category and category_title
attributes within the bundle or product class). Patch-handling attributes, including
applied_patches, is_patch, and patch_state. The fileset
architecture
attribute, which permits you to specify the architecture of the
target system on which the product will run.
In addition to adding new attributes and objects, layout_version 1.0
changes the following preexisting 0.8 objects and attributes as follows:
Replaces the depot
media_sequence_number
with the
media
object with a
sequence_number
attribute. Replaces the
vendor
definition within products and bundles with
a
vendor_tag
attribute and a corresponding
vendor
object defined outside the product or bundle. Pluralizes the
corequisite
and
prerequisite
fileset attributes (to
corequisites
and
prerequisites). Changes the
timestamp
attribute to
mod_time.
Applies to
swpackage,
swcopy,
swmodify,
and
swlist. - level=
Specifies a software
level
for
swlist,
swacl,
or
swreg. For
swlist: Lists all objects down to the specified
level.
Both the specified level(s) and the depth of the specified
software_selections
control the depth of the
swlist
output. The supported software levels are:
- bundle
Show all objects down to the bundle level. - product
Show all objects down to the product level. Also use
-l bundle -l product
to show bundles. - subproduct
Show all objects down to the subproduct level. - fileset
Show all objects down to the fileset level. Also use
-l fileset -l subproduct
to show subproducts. - file
Show all objects down to the file level (i.e. depots, products,
filesets, and files). - category
Show all categories of available software objects. - patch
Show all applied patches.
The supported depot and root levels are:
- depot
Show only the depot level (i.e. depots which exist at the specified target hosts). - root
List all alternate roots. - shroot
List all registered shared roots (HP-UX 10.X only). - prroot
List all registered private roots (HP-UX 10.X only).
The machine, user, and group levels apply only to HP OpenView Software Distributor PC target files.
- machine
Show the
machines
known to a PC controller. - user
Show the
users
known to a PC controller. - group
Show the
groups
known to a PC controller.
For
swacl: The
level
option defines the level of ACLs to view or modify:
- host
View/modify the ACL protecting the host system(s) identified by the
target_selections. - depot
View/modify the ACL protecting the software depot(s) identified by the
target_selections. - root
View/modify the ACL protecting the root file system(s) identified by the
target_selections. - product
View/modify the ACL protecting the software product identified by the
software_selection.
Applies only to products in depots, not installed products in roots. - product_template
View/modify the template ACL used to initialize the ACL(s) of future
product(s) added to the software depot(s) identified by the
target_selections. - global_soc_template
View/modify the template ACL used to initialize the ACL(s) of future
software depot(s) or root file system(s) added to the host(s)
identified by the
target_selections. - global_product_template
View/modify the template ACL used to initialize the
product_template
ACL(s) of future software depot(s) added to the host(s) identified by
the
target_selections.
For
swreg: The
level
option defines the level of object to register or unregister:
- depot
Depots which exist at the specified target hosts. - root
All alternate roots. - shroot
All registered shared roots (HP-UX 10.X only). - prroot
All registered private roots (HP-UX 10.X only).
Applies to
swacl,
swlist,
and
swreg.
- log_msgid=0
Controls whether numeric identification numbers are prepended to logfile
messages produced by SD:
- 0
(default) No identifiers are attached to messages. - 1
Applies to ERROR messages only. - 2
Applies to ERROR and WARNING messages. - 3
Applies to ERROR, WARNING, and NOTE messages. - 4
Applies to ERROR, WARNING, NOTE, and certain other logfile messages.
Applies to
swconfig,
swcopy,
swinstall,
swreg,
swremove,
and
swverify. - logdetail=false
The
logdetail
option controls the amount of detail written to the log file. When set
to
true,
this option adds detailed task information (such as options specified,
progress statements, and additional summary information) to the
log file. This information is in addition to log information controlled
by the
loglevel
option. Here are the possible combinations of
loglevel
and
logdetail
options: Applies to
swconfig,
swcopy,
swinstall,
swreg,
swremove,
and
swverify. - logfile=/var/adm/sw/sw<command>.log
Defines the default log file for each SD command.
(The agent log files are always located relative to the target depot or
target root, e.g.
/var/spool/sw/swagent.log
and
/var/adm/sw/swagent.log.) Applies to all commands except
swacl,
swlist,
and
swjob
(HP OpenView Software Distributor). - loglevel=1
Controls the log level for the events logged to the command logfile,
the target agent logfile, and the source agent logfile by prepending
identification numbers to SD logfile messages. This information
is in addition to the detail controlled by the
logdetail
option. See
logdetail
for more information. A value of
- 0
provides no information to the log files. - 1
enables verbose logging to the log files. - 2
enables very verbose logging to the log files.
Applies to
swconfig,
swcopy,
swinstall,
swmodify,
swpackage,
swremove,
and
swverify. - match_target=false
If set to
true,
software selection is done by locating filesets on the source that
match the target system's installed filesets. If multiple targets are
specified, the first in the list is used as the basis for selections. Applies to
swinstall. - max_agents=-1
The maximum number of agents that are permitted to run simultaneously.
The value of -1 means that there is no limit. Applies to
swagentd. - media_capacity=1330
If creating a distribution tape, this keyword specifies the capacity
of the tape in Mbytes. This option is required if the media is not a
DDS tape or a disk file. Without this option,
swpackage
sets the size to 1330 Mbytes for tape and "free space up to minfree"
on a disk file. Applies to
swpackage. - media_type=directory
Defines the type of distribution to create. The recognized types are
directory
and
tape. Applies to
swpackage. - minimum_job_polling_interval=1
This option applies only to HP OpenView Software Distributor.
Defines how often, in minutes, the daemon will wake up and scan the
job queue to determine if any scheduled jobs need to be initiated
or if any PC install jobs need their remote target status cached locally
(see
job_polling_interval
).
If set to 0, no
scheduled jobs will be initiated, and no caching of PC install
jobs will occur. Applies to
swagentd. - mount_all_filesystems=true
By default, the SD
commands attempt to mount all filesystems
in the
/etc/fstab
file at the beginning of the analysis phase,
to ensure that all listed filesystems are mounted before proceeding.
This policy helps to ensure that files are not loaded
into a directory that may be below a future mount point, and that
the expected files are available for a remove or verify operation. If set to
false,
the mount operation is not attempted, and no check of the current mounts
is performed. Applies to
swconfig,
swcopy,
swinstall,
swremove,
and
swverify. - mount_cmd=/sbin/mount
Defines the command called by the agent to mount all filesystems. Applies to
swagent. - objects_to_register=
Defines the default
objects to register or unregister.
There is no supplied default (see
select_local
above).
If there is more than one object, they must be separated by spaces. Applies to
swreg. - one_liner=
Defines the attributes which are listed in the non-verbose listing. Applies to
swlist
and HP OpenView Software Distributor's
swjob. - os_name
This option can be used in conjunction with
os_release
to specify fileset selection for an HP-UX update.
os_name
should only be specified from the command line. Refer to the SD
readme
file for correct syntax. You can display the
readme
file by entering: swlist -d -a readme SW-DIST [@ host:/depot ] Applies to
swinstall. - os_release
This option can be used in conjunction with
os_name
to specify fileset selection for an HP-UX update.
os_release
should only be specified from the command line. Refer to the SD
readme
file for correct syntax. You can display the
readme
file by entering: swlist -d -a readme SW-DIST [@ host:/depot ] Applies to
swinstall. - package_in_place=false
If set to
true,
swpackage
will package the specified products such that the target depot will not
contain the files that make up a product. Instead,
swpackage
inserts references to the original source files used to build a product.
This behavior allows products to be packaged
without consuming the full disk space of copying all the
source files into the target depot. Applies to
swpackage. - patch_commit=false
Commits a patch by removing files saved for patch rollback. When set to
true,
and run with
swmodify,
you cannot roll back (remove) a patch unless you remove the associated
base software that the patch modified. Applies to
swmodify. - patch_filter=*.*
Specifies a
software_specification
for a patch filter. The default value is
*.*. This option can be used in conjunction with the
autoselect_patches
and
patch_match_target
options to filter the selected patches to meet the criteria specified by
software_specification. Applies to
swask,
swcopy,
and
swinstall, - patch_match_target=false
If set to
true,
this option selects the latest patches (software identified by the
is_patch
attribute) that correspond to software on the target root or depot. The
patch_filter=
option can be used in conjunction with
patch_match_target. Applies to
swcopy
and
swinstall. - patch_one_liner=title patch_state
Specifies the attributes displayed for each object listed when the
-l patch
option is invoked and when no
-a
or
-v
option is specified. The default display attributes are
title
and
patch_state. Applies to
swlist
and
swjob. - patch_save_files=true
Saves patched files, which permits future rollback of patches. When set to
false,
patches cannot be rolled back (removed) unless the base software
modified by the patch is removed at the same time. Applies to
swinstall. - poll_now=false
This option applies only to HP OpenView Software Distributor.
The status information displayed for a PC install
job is as recent as the last time
the daemon polled remote targets for information (see the option
job_polling_interval).
If the most recent status is wanted set this option to
true. Applies to
swjob. - polling_interval=2
Defines in seconds the polling interval used by interactive (GUI)
sessions. It specifies how often each target agent will be polled to
obtain status information about the task being performed. When
operating across wide-area networks, the polling interval can be
increased to reduce network overhead. Applies to
swcopy,
swinstall,
and
swremove. - reboot_cmd=/sbin/reboot
Defines the command called by the agent to reboot the system. Applies to
swagent. - reconfigure=false
Prevents software which is already in the CONFIGURED state from being
reconfigured.
If set to
true,
CONFIGURED software can be reconfigured. Applies to
swconfig. - register_new_depot=true
Causes
swcopy
to register a newly created depot with the local
swagentd.
This action allows other SD commands to automatically "see" this depot.
If set to
false,
a new depot will not be automatically registered.
(It can be registered later with the
swreg
command.) Applies to
swcopy. - register_new_root=true
Causes
swinstall
to register a newly created alternate root with the local
swagentd.
This action allows other SD commands to automatically "see" this root.
If set to
false,
a new root will not be automatically registered.
(It can be registered later with the
swreg
command.) Applies to
swinstall. - reinstall=false
When re-installing (or re-copying) an existing version of a fileset, this
option causes that fileset to be skipped, i.e. not re-installed.
If set to
true,
the fileset will be re-installed (re-copied). Applies to
swinstall
and
swcopy. - reinstall_files=true
Causes all the files in a fileset to always be re-installed, re-copied,
or re-packaged, even when
the file already exists at the target and is identical to the new file.
If set to
false,
files that have the same
checksum
(see next option), size and time stamp will not be re-installed, re-copied,
or re-packaged. This
check enhances performance on slow networks or slow disks. Applies to
swinstall,
swcopy,
and
swpackage. - reinstall_files_use_cksum=true
This option affects the operation when the
reinstall_files
option is set to false.
It causes the checksums of the new and old file to be computed and compared
to determine if the new file should replace the old one.
(The checksum is slower, but is a more robust way to check for files being
equivalent.)
If set to
false,
the checksums are not computed, and files are (not) reinstalled based
only on their size and time stamp.
For
swpackage,
the default value for this option is
false. Applies to
swcopy,
swinstall,
and
swpackage. - remove_empty_depot=true
Remove an empty depot when the last product is removed.
If set to
false,
an empty depot will not be removed, preserving any depot ACLs. Applies to
swremove. - remove_fanout_depot=true
This option applies only to HP OpenView Software Distributor.
When an install job to a PC
is removed the software associated with that job is
automatically removed from the PC depot.
If the software that is part of this job is the same software
being used by another job, then be sure to not delete the software as
part of the job removal.
If the software on the PC depot should be retained, set this option to
false. Applies to
swjob. - remove_obsolete_filesets=false
Controls whether
swcopy
automatically removes obsolete filesets from target products in the
target depot. If set to
true,
swcopy
removes obsolete filesets from the target products that were written
to during the copy process. Removal occurs after the copy is
complete. Filesets are defined as obsolete if they were not part of
the most recent packaging of the product residing on the source depot. Applies to
swcopy. - remove_setup_cmd=/usr/lbin/sw/remove_setup
Defines the script called by the agent to perform release-specific
removal preparation. For an OS update, this script invokes the
tlink
command when a fileset is removed. Applies to
swagentd. - retry_rpc=1
Defines the number of times a lost source connection will be retried
during file transfers.
A lost connection is one
that has timed out. When used in conjunction with the
rpc_timeout
option, the success of installing over slow or busy networks
can be increased. If set to zero, then any
rpc_timeout
to the
source will cause the task to abort. If set from 1 to 9, then the
install of each fileset will be attempted that number of times.
The reinstall_files option should also be set to false to
avoid installing files within the fileset that were successfully
installed. Applies to
swcopy
and
swinstall. - rpc_binding_info=ncacn_ip_tcp:[2121] ncadg_ip_udp:[2121]
Defines the protocol sequence(s) and endpoint(s) on which the daemon
listens and on which the other commands use to contact the daemon.
If the connection fails for one protocol sequence, the next is
attempted.
SD supports both the tcp (ncacn_ip_tcp:[2121]) and udp
(ncadg_ip_udp:[2121]) protocol sequence on most platforms. The value
(or values for
swagentd)
can have
following form:
A DCE string binding containing a protocol sequence and an
endpoint. The syntax is:
protocol_sequence:[endpoint]. The name of a DCE protocol sequence with no endpoint specified. The
syntax is:
protocol_sequence,
for example
ncadg_ip_udp
or
ncacn_ip_tcp.
(A trailing
:
can be attached to the protocol sequence, it has no effect.)
Since no endpoint is specified, the DCE endpoint mapper
rpcd
must be running and will be used to find the endpoint registered by the
swagentd. The literal string
all.
This entry means to use (try) all protocol sequences supported by the DCE RPC.
It should be the only entry in the list.
The DCE endpoint mapper
rpcd
also must be running in order to use this option.
Applies to all commands except
swask,
swpackage,
and
swmodify. - rpc_binding_info_alt_source=ncadg_ip_udp:[2121]
Defines the protocol sequence(s) and endpoint(s) used when the agent
attempts to contact an alternate source depot specified by the
alternate_sourceoption.
HP-UX supports both the
udp(ncadg_ip_udp:[2121])
and
tcp(ncacn_ip_tcp:[2121])
protocol sequence/endpoint. SD on SunOS only supports udp
(ncadg_ip_udp:[2121]).
By default
udp
is used. Applies to
swagentd. - rpc_timeout=5
Relative length of the communications timeout. This is a value in the
range from 0 to 9 and is interpreted by the DCE RPC. Higher values
mean longer times; you may need a higher value for a slow or busy
network. Lower values will give faster recognition on attempts to
contact hosts that are not up, or are not running
swagentd.
Each value is approximately twice as long as the preceding value.
A value of 5 is about 30 seconds for the
ncadg_ip_udp
protocol sequence.
This option may not have any noticeable impact when using the
ncacn_ip_tcp
protocol sequence. Applies to all commands except
swpackage
and
swmodify. - select_local=true
If no
target_selections
are specified,
select the default
target_directory
of the local host as the
target_selection
for the command. Applies to
swacl,
swconfig,
swcopy,
swinstall,
swlist,
swreg,
swremove,
and
swverify. - software=
Defines the default
software_selections.
There is no supplied default.
If there is more than one software selection, they must be separated by spaces.
Software is usually specified in a software input
file, as operands on the command line, or in the GUI. Applies to all commands except
swreg
and HP OpenView Software Distributor's
swjob. - software_view=products
Indicates the software view to be used by the interactive interface of the
commands and by
swlist
for the default listing level.
It can be set to products, all_bundles, or a bundle
category tag (to indicate to show only bundles of that category). Applies to
swcopy,
swinstall,
swlist,
and
swremove. - source_cdrom=/SD_CDROM
Defines the default location of the source CD-ROM. This syntax can be
host:path. Applies to
swinstall. - source_depot_audit=true
If both source and target machine are updated to HP-UX version 10.30
or later, the system administrator at the source depot machine
can set this option to track
which
user pulls
which
software from a depot on the source machine and
when
the software is pulled. (Note that a user running
swinstall/swcopy
from a target machine cannot set this option; only the administrator
of the source depot machine can set it.) When
source_depot_audit
is set to
true,
a
swaudit.log
file is created on the source depot (for writable directory depots)
or in
/var/tmp
(for
tar
images, CD-ROMs, or other non-writable depots). Users can invoke the
swlist
interactive user interface (using
swlist -i -d)
to view, print, or save the audit information on a remote or
local depot. Users can view audit information based
on language preference, as long as the system has
the corresponding SD message catalog files on it. For example,
a user can view the source audit information in Japanese
during one invocation of
swlist,
then view the same information in English
at the next invocation. Applies to
swagent,
swinstall,
and
swlist.
- source_file=psf
Defines the default location of the source product specification file
(PSF). The
host:path
syntax is not allowed, only a valid
path
can be specified.
The
-s
option overrides this value. Applies to
swpackage
and
swmodify. - source_tape=/dev/rmt/0m
Defines the default location of the source tape, usually the
character-special file of a local tape device. If the
host:path
syntax is used, the host must match the local host.
The
-s
option overrides this value. Applies to
swcopy
and
swinstall. - source_type=directory
Defines the default source type:
cdrom,
file,
directory,
or
tape.
The source type derived from the
-s
option overrides this value. Applies to
swcopy,
swinstall,
and
swpackage.
(The values
cdrom,
and
tape
apply to
swcopy
and
swinstall
only. The value
file
applies to
swpackage
only.) - system_file_path=/stand/system
Defines the path to the kernel's template file. This path is passed
to the
system_prep_cmd
via the
SW_SYSTEM_FILE_PATH
environment variable. Applies to
swagent. - system_prep_cmd=/usr/lbin/sysadm/system_prep
Defines the kernel build preparation script called by the agent.
This script must do any necessary preparation so that control
scripts can correctly configure the kernel about to be built. This
script is called before any kernel filesets have been loaded. Applies to
swagent.
- targets=
Defines the default
target_selections.
There is no supplied default (see
select_local
above).
If there is more than one target selection, they must be separated by spaces.
Targets are usually specified in a target input
file, as operands on the command line, or in the GUI. Applies to all commands. - uncompress_cmd=
Defines the command to uncompress files
when installing, copying, or packaging.
This command processes files which were stored on the
media in a compressed format. If the
compression_type
of the file is
gzip
then the internal uncompression
(funzip)
is used instead of the external
uncompress_cmd. Applies to
swpackage
and
swagent. - uncompress_files=false
If the files being transferred from a source are compressed, setting
this option will uncompress the files before storing them on the
target depot. Applies to
swcopy
and
swpackage. - use_alternate_source=false
Empowers each target agent to use its own, configured alternate source, instead
of the one specified by the user.
If
false,
each target agent will use the same source, namely the source specified by
the user and validated by the command.
If
true,
each target agent will instead use its own configured value for the source. Applies to
swcopy
and
swinstall. - verbose=
Controls the verbosity of a non-interactive command's output:
- 0
disables output to stdout. (Error and warning messages
are always written to stderr). - 1
enables verbose messaging to stdout. - 2
for
swpackage
and
swmodify,
enables very verbose messaging to stdout.
For the
swlist
command, a verbose listing includes all attributes that have been
defined for the appropriate
level of each
software_selection
operand. The attributes are listed, one per line, prefaced
by the attribute keyword. The
-v
option overrides this default if it is set to 0. Applies to all commands. - write_remote_files=false
Prevents the installation, copying, or packaging of files to a target which
exists on a remote (NFS) file system. Also prevents the removal of files from
a remote file system.
All files destined for (or already on) a remote file system will be skipped. If set to
true
and if the superuser has write permission on the remote
file system, the remote files will not be skipped, but will be installed,
copied, packaged, or removed. Applies to
swcopy,
swinstall,
swpackage,
and
swremove.
Session FilesEach invocation of an SD command defines a task session. Most SD
commands automatically save options, source information, software
selections, and target selections before the task actually
commences. This lets you re-execute the command even if the session
ends before the task is complete. You can also save session
information from interactive or command-line sessions. Session information is saved to the file
$HOME/.sw/sessions/command_name.last.
This file is overwritten by each invocation of the command. The file
uses the same syntax as the defaults files. From an interactive session, you can save session information
into a file at any time by selecting the
Save Session
or
Save Session As
option from the
File
menu. From a command-line session, you can save session information by
executing the command with the
-C session__file
option. You can specify an absolute path for a session file. If you do
not specify a directory, the default location is
$HOME/.sw/sessions/. To re-execute a saved session from an interactive session, use the
Recall Session
option from the
File
menu. To re-execute a session from a command-line, specify the session file
as the argument for the
-S
option. When you re-execute a session file, the values in the session file
take precedence over values in the system defaults file. Likewise,
any command-line options and parameters take precedence over the
values in the session file. Software and Target ListsMost SD commands support software and target selections from separate
input files (see the
-f
and
-t
options).
Software and targets specified in these files will be selected for operation. Additionally, commands that support an interactive interface read
a list of possible hosts to operate on from the values found in:
- /var/adm/sw/defaults.hosts
the system-wide default list of hosts, - $HOME/.sw/defaults.hosts
the user-specific default list of hosts.
Hosts in this file are not marked for operation, but provide a default
list from which to choose. For each interactive command, target hosts
containing roots, containing depots, and hosts serving as fanout
servers are specified in separate lists (
hosts,
hosts_with_depots,
and
fanout_servers
respectively). The list of hosts are enclosed in {} braces and
separated by white space (blank, tab and newline). For example:
swinstall.hosts={hostA hostB hostC hostD
hostE hostF}
swinstall.fanout_servers={pc1 pc2} (HP OpenView Software Distributor only)
swcopy.hosts_with_depots={hostS}
swcopy.fanout_servers={pc1 pc2} (HP OpenView Software Distributor only)
swremove.hosts={hostA hostB hostC hostD
hostE hostF}
swremove.hosts_with_depots={hostS} Most SD commands support patch filtering with the
-x patch_filter=software_specification
option. In addition, the interactive user interface commands,
swinstall
and
swcopy
read a list of possible patch filters. The user can use the values
from this list for selection criteria. The lists are stored in:
- /var/adm/sw/defaults.patchfilters
the system-wide default list of patch filters. - $HOME/.sw/defaults.patchfilters
the user-specific default list of patch filters.
Filters in this file are not marked for selection use but provide a
default list from which the user can choose. The list of patch filters
is enclosed in braces {} and separated by white space (blank, tab, or
newline). For example:
swinstall.patch_filter_choices={
*.*,c=enhancement
*.*,c=critical
}
swremove.patch_filter_choices={
Product.Fileset,c=halts_system
} The following PC information applies to HP OpenView Software Distributor only.
For installing to PCs,
PC target lists are generated automatically by querying the PC file server
associated with a PC controller.
Any user, group, or machine known to the file server will be
included in the default list from which to choose.
Additionally, all machines known to the file server will by default be selected
for installation when selecting a PC controller. Environment VariablesSD programs are affected by external environment variables, set
environment variables for use by the control scripts, and set additional
environment variables that affect scripts run by
swinstall
and
swremove. External environment variables that affect the SD commands: - LANG
Determines the language in which messages are displayed.
If LANG is not specified or is set to the empty string, a
default value of
C
is used.
See
lang(5)
for more information. NOTE: The language in which the SD agent and daemon log messages
are displayed is set by the system configuration variable script,
/etc/rc.config.d/LANG.
For example,
/etc/rc.config.d/LANG,
must be set to
LANG=ja_JP.SJIS
or
LANG=ja_JP.eucJP
to make the agent and daemon log messages display in Japanese. This variable applies to all SD commands except
swgettools.
Environment variables that affect scripts: - SW_CONTROL_DIRECTORY
Defines the current directory of the script being executed, either
a temporary catalog directory, or a directory within in the
Installed Products Database (IPD).
This variable tells scripts where other control scripts for the software
are located (e.g. subscripts). - SW_LOCATION
Defines the location of the product, which may have been changed from
the default product directory. When combined with the
SW_ROOT_DIRECTORY,
this variable tells scripts where the product files are located. - SW_PATH
A PATH variable which defines a minimum set of
commands available to for use in a control script
(e.g.
/sbin:/usr/bin). - SW_ROOT_DIRECTORY
Defines the root directory in which the session is operating, either
"/" or an alternate root directory.
This variable tells control scripts the root directory in which the
products are installed. A script must use this directory as a prefix
to SW_LOCATION to locate the product's installed files.
The configure script is only run when
SW_ROOT_DIRECTORY is "/". - SW_SESSION_OPTIONS
Contains the pathname of a file containing the value of every option
for a particular command, including software and target
selections. This lets scripts retrieve any command
options and values other than the ones provided explicitly by
other environment variables. For example, when the file pointed to by
SW_SESSIONS_OPTIONS
is made available to a
request
script, the
targets
option contains a list of
software_collection_specs
for all targets specified for the command. When the file pointed to by
SW_SESSIONS_OPTIONS
is made available to other scripts, the
targets
option contains the single
software_collection_spec
for the targets on which the script is being executed. - SW_SOFTWARE_SPEC
This variable contains the fully qualified software specification of
the current product or fileset. The software specification allows the
product or fileset to be uniquely identified.
Additional environment variables that affect scripts run by
swinstall
and
swremove: - SW_DEFERRED_KERNBLD
Only applies to
swinstall.
This variable is normally unset. If it is
set, the actions necessary for preparing the
system file
/stand/system
cannot be
accomplished from within the
postinstall
scripts, but instead must be accomplished by
the
configurescripts.
This occurs whenever
software is installed to a directory other
than
/,
such as for a cluster client system.
This variable should be read only by the
configure
and
postinstall
scripts of a kernel fileset. The
swinstall
command sets these environment variables for use by the kernel
preparation and build scripts. - SW_INITIAL_INSTALL
Only applies to
swinstall.
This variable is normally unset. If it is
set, the
swinstall
session is being run as the
back end of an initial system software
installation ("cold" install). - SW_KERNEL_PATH
Only applies to
swinstall.
The path to the kernel. The default value is
/stand/vmunix,
defined by the
swagent
option or
kernel_path. - SW_SESSION_IS_KERNEL
Indicates whether a kernel build is scheduled for the current
install/remove session. A
TRUE
value indicates that the selected kernel fileset is scheduled for
a kernel build and that changes to
/stand/system
are required.
A null value indicates that a kernel build is not scheduled and that
changes to
/stand/system
are not required. The value of this variable is always equal to the value of
SW_SESSION_IS_REBOOT. - SW_SESSION_IS_REBOOT
Indicates whether a reboot is scheduled for a fileset selected for
removal. Because all HP-UX kernel filesets are also reboot filesets,
the values of this variables is always equal to the value of
SW_SESSION_IS_KERNEL. - SW_SYSTEM_FILE_PATH
Only applies to
swinstall.
The path to the kernel's system file. The
default value is
/stand/system.
SignalsThe SD commands catch the signals SIGQUIT and SIGINT.
If these signals are received, the command prints a message, sends
a Remote Procedure Call (RPC) to the agents to wrap up, and then exits. The
agent ignores SIGHUP, SIGINT, and SIGQUIT. It immediately exits
gracefully after receiving SIGTERM, SIGUSR1, or SIGUSR2.
Killing the agent may leave corrupt software on the system, and thus should
only be done if absolutely necessary. Note that when an
SD command is killed, the agent does not terminate until completing the
task in progress. The daemon ignores SIGHUP, SIGINT and SIGQUIT. It immediately exits
gracefully after receiving SIGTERM and SIGUSR2. After receiving
SIGUSR1, it waits for completion of a copy or remove from a depot
session before exiting, so that it can register or unregister depots
if necessary. Requests to start new sessions are refused during this wait.
LockingSD commands use a common locking mechanism for reading and modifying
both root directories and software depots. This mechanism
allows multiple readers but only one writer on a root or depot. The SD
commands which modify software in an (alternate) root directory are restricted from simultaneous
modification using
fcntl(2)
locking on the file
var/adm/sw/products/swlock relative to the root directory
(e.g.
/var/adm/sw/products/swlock). The SD
commands which modify software in a depot are restricted from
simultaneous modification using
fcntl(2)
locking on the file
relative to the depot directory (e.g.
/var/spool/sw/catalog/swlock). All commands set
fcntl(2)
read locks on roots and depots using the
swlock
file mentioned above.
When a read lock is set, it prevents other SD commands from performing
modifications (i.e. from setting write locks). RETURN VALUESEach SD command invocation returns:
- 0
The sw<task> successfully completed. - 1
The sw<task> failed on all
target_selections. - 2
The sw<task> failed on some
target_selections.
DIAGNOSTICSThe
swconfig,
swcopy,
swinstall,
swmodify,
swpackage,
swremove,
and
swverify
commands support a preview mode, where operation
will proceed through the analysis
of each
target_selection,
then exit before the actual task is performed. The
HP OpenView Software Distributor interactive interface
(invoked using the
sd
command)
and the
swjob
command can be used to view the current status of any job
as well as the controller and target log files. Preview is only applicable for non-interactive operation, since the
interactive commands wait for confirmation after analysis. In the interactive
mode, you can resolve invalid conditions that the commands discover before
they actually begin loading or removing files. Standard OutputWhen non-interactive,
the commands write messages for significant events.
These events include:
a begin and end task message, a message for starting the task on each host, and a message for completing the task on each host.
When the
verbose
option is set, summary messages about the task are also sent to the standard output. Standard ErrorWhen non-interactive, the commands also write messages for the following
significant error events:
a message for each host failing analysis and a message for each host failing the actual task.
LoggingAll
commands log major events on the host where the command was invoked.
They log detailed events to the
swagent
log associated with each
target_selection.
- Command Log
The commands log messages to
/var/adm/sw/sw<task>.log.
(The user can specify a different logfile by
modifying the
logfile
option.) - Target Log
A
swagent
process performs the actual
swacl,
swconfig,
swcopy,
swinstall,
swremove,
and
swverify
operation at each
target_selection.
For operations on target root objects,
the
swagent
logs messages to the file
var/adm/sw/swagent.log
beneath the root directory (e.g.
/
or an alternate root directory).
For operations on target depot objects,
the
swagent
logs messages to the file
swagent.log
beneath the depot directory (e.g.
/var/spool/sw). The
swagentd
running on a host logs events to the file
/var/adm/sw/swagentd.log. - Source Depot Audit Log
If both source and target machine are updated to HP-UX version 10.30
or later, the system administrator at the source depot machine
can track
which
user pulls
which
software from a depot on the source machine and
when
the software is pulled. Refer to the
source_depot_audit
option in
swagent(1M)
for more information.
The following PC information applies to HP OpenView Software Distributor only.
On a PC controller,
SWAGENTD.EXE
logs events and messages to the file
...\SD\DATA\SWAGENTD.LOG.
Command, agent, and target log files can be viewed using the
swjob
command. LIMITATIONSThe following PC information applies to HP OpenView Software Distributor only.
For PCs, the SD commands generally only apply to the PC controller, or
the PC depot on the PC controller.
The
swinstall
and
swjob
commands indirectly install to and retrieve information from PC targets. The
swpackage
command is not used for PC software. PC software is packaged using the
PC Console on the PC controller, then copied (with
swcopy)
to a UNIX depot for subsequent distribution. FILES- /dev/rmt/0m
Default source tape location. - /etc/fstab
List of volumes that should be mounted. - $HOME/.swdefaults
Contains the user-specific default values for some or all SD
options. If this file does not exist, SD looks for user-specific
defaults in
$HOME/.sw/defaults. - $HOME/.sw/defaults.hosts
Contains the user-specific default list of hosts to manage. - $HOME/.sw/defaults.patchfilters
Contains the user-specific default list of patch filters. - $HOME/.sw/sessions/
Contains session files automatically saved by the SD commands, or
explicitly saved by the user. - /usr/lbin/swagent
The SD agent. - /usr/lib/nls/$LANG/sw*.cat
The SD message catalogs. - /usr/lib/sw/help/
The directory which contains the help files used by the
SD GUIs' on-line help facility. - /usr/lib/sw/sys.defaults
Contains the master list of current SD options (with their default values). - /usr/lib/sw/ui/
The directory which contains the description files used by the
SD Graphical User Interfaces (GUIs). - /usr/newconfig/var/adm/sw/
The directory containing the configurable data shipped for the SD
product, which is conditionally copied into
/var/adm/sw/
based on the existing configuration. - /usr/sbin/sw*
The SD commands. - /var/adm/sw/
The directory which contains all of the configurable
(and non-configurable) data for SD.
This directory is also the default location of log files. - /var/adm/sw/defaults
Contains the active system-wide default values for some or all SD options. - /var/adm/sw/defaults.hosts
Contains the system-wide default list of hosts to manage. - /var/adm/sw/defaults.patchfilters
Contains the system-wide default list of patch filters. - /var/adm/sw/getdate.templ
Contains the set of date/time templates used when scheduling jobs. - /var/adm/sw/host_object
The file which stores the list of depots registered at the local host. - /var/adm/sw/products/
The Installed Products Database (IPD), a catalog of all products
installed on a system. - /var/adm/sw/queue/
The directory which contains the information about all active and complete
install, remove, and other jobs initiated by the SD commands. Applies
to HP OpenView Software Distributor only.. - /var/adm/sw/security/
The directory which contains ACLs for the system itself, template ACLS,
and the secrets file used to authenticate remote requests. - /var/spool/sw/
The default location of a source and target software depot.
The following applies to HP OpenView Software Distributor only.
- /usr/lib/sw/examples/
The directory containing an example depot and example swpackage data. - /usr/OV/help/$LANG/sd/
The directory which contains the help files used by the SD integration
into OpenView. - /usr/OV/registration/$LANG/sd.reg
The registration file which integrates SD into the HP OpenView Network
Node Manager.
PC FILESThe following applies to HP OpenView Software Distributor only.
- ...\SD\AGENTS\*.EXE
The SD PC agents. - ...\SD\CONSOLE\*.EXE
The SD PC commands. - ...\SD\DATA\
The directory which contains all of the configurable
and non-configurable data for SD. - ...\SD\DATA\DEPOT\
The default location of the source and target PC depot. - ...\SD\DATA\NADMIN.DST
The database which defines all PC distribution jobs and PC target status. - ...\SD\DATA\NADMIN.INV
The database which defines all PC target machines available for fanout installation. - ...\SD\DATA\QUEUE\
The directory which contains the information about all active and complete
install, remove, and other jobs initiated by the SD commands. - ...\SD\DATA\SECURITY\
The directory which contains ACLs for the system itself, template ACLS,
and the secrets file used to authenticate remote requests. - ...\SD\DATA\SWAGENTD.LOG
The log of all actions and events performed by the PC controller. - <WINDOWS>\NADMIN.INI
Contains the configurable options for the SD PC console. - <WINDOWS>\SWAGENTD.INI
Contains the configurable options for the SD PC controller.
AUTHORSoftware Distributor was developed by the Hewlett-Packard Company.
swagent,
swcopy,
swinstall,
swlist,
and
swpackage
were developed by the Hewlett-Packard Company and Mark H. Colburn (see
pax(1)). SEE ALSOsd(4),
swacl(1M),
swagentd(1M),
swask(1M),
swconfig(1M),
swcopy(1M),
swgettools(1M),
swinstall(1M),
swjob(1M),
swlist(1M),
swmodify(1M),
swpackage(1M),
swpackage(4),
swreg(1M),
swremove(1M),
swverify(1M), Managing HP-UX Software with SD-UX
manual HP OpenView Software Distributor Administrator's Guide.
|