 |
» |
|
|
|
NAMElvlnboot — prepare LVM logical volume to be root, boot, primary swap, or dump volume SYNOPSIS/usr/sbin/lvlnboot
[[-A
autobackup]
{
-b
boot_lv
|
-d
dump_lv
|
-r
root_lv
|
-R
|
-s
swap_lv
}]
[-v]
[vg_name] /usr/sbin/lvlnboot
[-c] Remarkslvlnboot
cannot be performed if the volume group is activated in shared mode. DESCRIPTIONThe
lvlnboot
command updates all physical volumes in the volume group
so that the logical volume becomes the root, boot, primary swap, or a dump
volume when the system is next booted on the volume group.
If a nonexistent logical volume is specified, this command fails.
If a different logical volume is already linked
to the root or primary swap, the command fails. This command should be run in recovery mode
(-R)
whenever the configuration of the root volume group
is affected by one of the following commands:
lvextend,
lvmerge,
lvreduce,
lvsplit,
pvmove,
lvremove,
vgextend,
or
vgreduce
(see
lvextend(1M),
lvmerge(1M),
lvreduce(1M),
lvsplit(1M),
pvmove(1M),
lvremove(1M),
vgextend(1M),
and
vgreduce(1M)).
Starting with HP-UX Release 10.0, this is done automatically. Options and Argumentslvlnboot
recognizes the following options and arguments:
- vg_name
The path name of a volume group. - -A autobackup
Set automatic backup for this invocation of this command.
autobackup
can have one of the following values:
- y
Automatically back up configuration changes made to the logical volume.
This is the default. After this command executes, the
vgcfgbackup
command (see
vgcfgbackup(1M))
is executed for the volume group to which the logical volume belongs. - n
Do not back up configuration changes this time.
- -b boot_lv
Define
boot_lv
to be the boot volume the next time the system is booted on
the volume group.
boot_lv
must be the first logical volume on the physical volume.
boot_lv
must be contiguous, and must not allow bad block relocation. boot_lv
is used to locate the boot file system during the boot process.
The boot file system has the kernel which is read by the boot loader
hpux(1M). - -d dump_lv
Define
dump_lv
to be one of the dump volumes
the next time the system is booted on the volume group.
dump_lv
must be a contiguous logical volume and cannot have
Bad Block Relocation enabled. The command updates the Boot Data Reserved Area of
each bootable physical volume in the volume group (see
pvcreate(1M)). The combined size of all the dump volumes
should be at least 2048 bytes larger
than the total memory of the system.
The additional 2 KB is used to safeguard
against a dump to the bottom of the disk. Multiple dump devices can be configured,
but each
dump_lv
must be entered with a separate
lvlnboot
command line. - -r root_lv
Define
root_lv
to be the root volume
the next time the system is booted on this volume group.
root_lv
must be a contiguous logical volume
and cannot have bad block relocation enabled. If
root_lv
is the first logical volume on the physical volume,
then it is configured as the combined root-boot
volume. Otherwise,
root_lv
is configured as the separate root volume in which case
a separate boot volume needs to be configured using the
lvlnboot -b
option. Either the separate root or the separate boot volume can be configured
first. The command updates the Boot Data Reserved Area of
each bootable physical volume (see
pvcreate(1M))
to enable the volume group to be used to locate the root file system.
root_lv
is also used as the root volume during a maintenance-mode boot (see
hpux(1M)). The physical volumes containing
root_lv
must have been created using the
pvcreate -B
option (see
pvcreate(1M)),
indicating that that physical volume is to be used
as a bootable physical volume.
Also, the
mkboot
command (see
mkboot(1M))
must have been run on the physical volume
to create the LIF area at the top of the physical volume (see
lif(4)). - -R
Recover any missing links to all of the logical volumes
specified in the Boot Data Reserved Area and update
the Boot Data Reserved Area of
each bootable physical volume in the volume group (see
pvcreate(1M)). - -s swap_lv
Define
swap_lv
to be the primary swap volume
the next time the system is booted on the volume group.
swap_lv
must be a contiguous logical volume,
and a root logical volume must have been previously defined
with this command. The command updates the Boot Data Reserved Area of
each bootable physical volume in the volume group (see
pvcreate(1M)).
Any existing swap area previously defined must be removed
via
lvrmboot(1M). - -c
During normal boots (vs. maintenance-mode boots, see
hpux(1M)),
this command is automatically executed by
/sbin/ioinitrc
(see
inittab(4)). Since this command is performed during boot, it does
not need to be performed manually unless
/stand/rootconf
is missing in a separate root/boot configuration (or
alternatively, performing a normal reboot will recreate this file). This command updates the
/stand/rootconf
file with the location of the root volume in the currently booted
volume group. The
/stand/rootconf
file is used during maintenance-mode boots
to locate the root volume for volume groups with separate boot and
root volumes. During maintenance-mode boots, since the root volume group is not activated,
lvlnboot -c
does not update
/stand/rootconf.
For separate root/boot configurations, maintenance-mode boot
will fail if
/stand/rootconf
does not already exist with the correct location of the
root volume. See
WARNINGS. When a new volume group with separate boot and root volumes
is created, the first boot must be a normal boot (versus.
a maintenance-mode boot), so that
/stand/rootconf
gets created. This option does not allow updating
/stand/rootconf
for any volume group other than the one that is booted. - -v
Print verbose messages.
With no other arguments present,
print information on root, boot, swap, and dump logical volumes.
If a combined root-boot volume is configured, no information for
the boot volume is displayed.
EXTERNAL INFLUENCESEnvironment VariablesLANG
determines the language in which messages are displayed. If
LANG
is not specified or is null, it defaults to
"C" (see
lang(5)). If any internationalization variable contains an invalid setting,
all internationalization variables default to "C" (see
environ(5)). EXAMPLESThe following examples show configuration of a combined root-boot
volume.
Create a root volume group,
vglvmroot,
containing root, swap, and dump logical volumes.
Assume that an appropriate directory called
/dev/vglvmroot
and a corresponding
group
file already exist (see
lvm(7)). First, initialize the disk, say
/dev/dsk/c0t0d0,
so that it can be used as an LVM boot disk.
pvcreate -B /dev/rdsk/c0t0d0 Place the LIF information on the disk using the
mkboot
command.
Create the volume group
vglvmroot.
vgcreate /dev/vglvmroot /dev/dsk/c0t0d0 Create a logical volume that is suitable for use as the root volume.
This logical volume has to be the first in the volume group
and should be a contiguous volume with bad block relocation turned off.
lvcreate -n root -L 120 -C y -r n /dev/vglvmroot Create a logical volume that will be used as primary swap.
This volume should be contiguous.
lvcreate -n swap -L 64 -C y /dev/vglvmroot Create a logical volume that will be used as the dump volume.
This volume should be contiguous.
lvcreate -n dump -L 64 -C y /dev/vglvmroot Specify that the logical volume,
root,
will be used as the root volume.
lvlnboot -r /dev/vglvmroot/root Specify that the logical volume,
swap,
will be used as the primary swap.
lvlnboot -s /dev/vglvmroot/swap Specify that the logical volume,
dump,
will be used
as the dump volume.
lvlnboot -d /dev/vglvmroot/dump Display the results of the previous operations.
lvlnboot -v /dev/vglvmroot
The following examples show configuration of separate root and boot volumes.
Create a root volume group,
vglvmroot,
containing root, boot, swap, and dump logical volumes.
Assume that an appropriate directory called
/dev/vglvmroot
and a corresponding
group
file already exist (see
lvm(7)). First, initialize the disk, say
/dev/dsk/c0t0d0,
so that it can be used as an LVM boot disk.
pvcreate -B /dev/rdsk/c0t0d0 Place the LIF information on the disk using the
mkboot
command.
Create the volume group
vglvmroot.
vgcreate /dev/vglvmroot /dev/dsk/c0t0d0 Create a logical volume that is suitable for use as the boot volume.
This logical volume has to be the first in the volume group
and should be a contiguous volume with bad block relocation turned off.
lvcreate -n boot -L 24 -C y -r n /dev/vglvmroot Create a logical volume that is suitable for use as the root volume.
This logical volume should be a contiguous volume with bad block
relocation turned off.
lvcreate -n root -L 64 -C y -r n /dev/vglvmroot Create a logical volume that will be used as primary swap.
This volume should be contiguous.
lvcreate -n swap -L 64 -C y /dev/vglvmroot Create a logical volume that will be used as the dump volume.
This volume should be contiguous.
lvcreate -n dump -L 64 -C y /dev/vglvmroot Specify that the logical volume,
root,
will be used as the root volume.
lvlnboot -r /dev/vglvmroot/root Specify that the logical volume,
boot,
will be used as the boot volume.
lvlnboot -b /dev/vglvmroot/boot Specify that the logical volume,
swap,
will be used as the primary swap.
lvlnboot -s /dev/vglvmroot/swap Specify that the logical volume,
dump,
will be used as the dump volume.
lvlnboot -d /dev/vglvmroot/dump Display the results of the previous operations.
lvlnboot -v /dev/vglvmroot
The following example shows configuration of multiple dump volumes. Specify that logical volumes
/dev/vg00/swap1,
/dev/vg00/dump2,
and
/dev/vg00/dump3
should be used as the dump logical volumes and that
/dev/vg00/swap1
should also be used as primary swap. Assume that the volume group and
the logical volumes have been created and the logical volumes are
contiguous. lvlnboot -s /dev/vg00/swap1
lvlnboot -d /dev/vg00/swap1
lvlnboot -d /dev/vg00/dump2
lvlnboot -d /dev/vg00/dump3 WARNINGSDump Volume WarningsA dump logical volume, or a swap logical volume used as a dump volume,
must lie within the first 2 GB (< 2 GB) of the physical volume.
The
lvlnboot
command will not allow a dump logical volume to be configured
that crosses the 2 GB boundary,
but it will allow such a swap logical volume to be configured. For a system with high-density memory boards installed,
lvlnboot
will be able to support dump logical volumes up to 4 GB of the physical volume. If the swap device is used as a dump volume by specifying the
dump
default in the system file (see
config(1M)),
care should be taken to ensure that the swap logical volume
does not exceed the 2 GB boundary (or 4 GB for the system
as mentioned above). Separate Root/Boot WarningsWhenever
mkboot(1M)
is used to restore the LIF area of a damaged root physical volume, the
-b
boot_lv
option of
lvlnboot
must be performed afterwards to record the boot volume information inside
the new LIF (see
lif(4)).
Subsequent
lvlnboot
commands such as
lvlnboot -R
are dependent on the
boot_lv
information inside the LIF. If the
-v
option does not locate the boot volume
boot_lv,
and the
-r
root_lv
has not yet been performed, then performing the
-r
root_lv
option will enable the boot volume to be located.
The
lvlnboot
command derives the location of boot volume
from the location of the root volume. Separate Root/Boot Maintenance-Mode WarningsWhen creating additional root volumes with separate root/boot,
a normal boot must be performed on each new root volume so that
/stand/rootconf,
which is required for maintenance-mode boots (see
hpux(1M)),
gets created for each new root volume. Mirrored
root_lv
volumes should start at the same offset on each physical volume
so that the location stored in
/stand/rootconf
works for maintenance-mode boots off of any mirror. FILES- /stand/rootconf
Contains the location of the root volume. Used during
maintenance-mode boots (see
hpux(1M))
to locate the root volume for volume
groups with separate boot and root volumes.
|